Data Comm for Business, Inc.

Your Complete Data Communications Solution Provider

SR Multiplexers with Frame Relay and Cisco Routers

Overview:

The SR Multiplexer and Cisco routers can be configured to allow SR Multiplexers to co-exist with LAN traffic on a frame relay wide area network. This is useful for cut-overs when moving from a multiplexer based WAN to one based on TCP/IP peers. It also allows PC based LAN traffic to use the same frame relay WAN with RS-232 traffic.

Applications:

Cut-overs: This is quite useful for cut-overs. When moving a multiplexer-based WAN to a frame-relay based TCP/IP WAN, this method can be used to minimize cut-over down time and the need for overlapping wide area communication facilities.

Bandwidth sharing between RS-232 and TCP/IP traffic: This technique allows the sharing of bandwidth between TCP/IP and RS-232 traffic. Remote offices that need the LAN connectivity for email and file transfers along with RS-232 connectivity for a host-based service will benefit from reduced cost, no duplicated facilities, and higher performance on the RS-232 system.

Legacy Applications: Running character-based UNIX applications from a remote host while using LAN based internetworking adds greatly to system flexibility. This removes the need to run special TCP/IP stacks on local PC's, configuration of host minicomputers, and expensive PC reconfiguration when moving to LAN based applications.

Out-of-Band Network Management: Allows remote network management using RS-232 access switch products to share bandwidth on the WAN. This has some drawbacks, since there is no connectivity when the network is down, but is useful for remote management of many devices such as hubs, switching hubs, and servers.

Test Bed Hardware:

The test bed configuration used Cisco 2501 routers, each configured with two serial ports and one LAN port, two SR multiplexers with frame-relay firmware, and appropriate DSU's (two DCB FT-1's) as show in figure one.

Procedure:

1. The SR multiplexers were configured with all defaults, including AUTO sensing the frame relay management type. Port configuration is unimportant for this demonstration.

2. The Cisco routers were configured as in Listing One and Listing Two. For this demonstration, no IP routing is shown.

3. After connections were completed, test the circuit by performing remote test loops on the SR multiplexers. Using the Testing Tools menu, measure round-trip delay and verify that the multiplexers loop back QBF messages.

Notes:

1. The Cisco router must provide clock for the multiplexer. Use Cisco cable # CAB232FC between the router and multiplexer.


Listing 1. Configuration for Cisco Router named ROUTER25:

router25>enable 
router25#show config 
Using 544 out of 32762 bytes 
! 
version 10.3 
service tcp-small-servers
 !
hostname router25
!
frame-relay switching
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 no ip address
 encapsulation frame-relay
 frame-relay lmi-type q933a
 frame-relay type nni
 frame-relay route 17 interface Serial1 16
!
interface Serial1
 no ip address
 encapsulation frame-relay
 clockrate 56000
 frame-relay lmi-type ansi
 frame-relay intf-type dce
 frame-relay route 16 interface Serial0 17
!
line con 0
line aux 0
 transport input all
line vty 0 4
 login
!
end

LISTING 2. Configuration for Cisco router named ROUTER28:

 
router28#show config 
Using 710 out of 32762 bytes 
!
version 10.3
service config
service tcp-small-servers
!
hostname router28
!
no ip routing
frame-relay switching
!
interface Ethernet0
 no ip address
 no ip route-cache
 shutdown
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no ip route-cache
 frame-relay lmi-type q933a
 frame-relay intf-type nni
 frame-relay route 17 interface Serial1 16
!
interface Serial1
 no ip address
 encapsulation frame-relay
 no ip route-cache
 clockrate 56000
 frame-relay intf-type dce
 frame-relay route 16 interface Serial0 17
!
line con 0
 exec-timeout 0 0
line aux 0
 transport input all
line vty 0 4
 login
!
end
router28#

Back